Cảnh báo lỗ hổng CVE-2024-4577 trong PHP

Thứ ba - 11/06/2024 10:41 295 0
Trung tâm ứng cứu khẩn cấp không gian mạng Việt Nam (VNCERT/CC), Cục An toàn thông tin cảnh báo về lỗ hổng CVE-2024-4577 trong PHP nhằm cung cấp thêm thông tin cần thiết để quản trị viên cũng như người dùng có thể thực hiện các biện pháp bảo mật một cách kịp thời và hiệu quả.
lh

Thông tin về lỗ hổng

CVE-2024-4577 là một lỗ hổng bảo mật nghiêm trọng trong PHP. Lỗ hổng này xảy ra khi sử dụng Apache và PHP-CGI trên hệ điều hành Windows, nếu hệ thống được cấu hình để sử dụng một số bảng mã (code pages) nhất định. Khi đó, Windows có thể sử dụng cơ chế “Best-Fit” để thay thế các ký tự trong dòng lệnh được truyền tới các hàm Win32 API. Điều này có thể làm cho mô-đun PHP-CGI hiểu sai các ký tự này như là các tùy chọn của PHP.

Lỗ hổng này có thể cho phép một kẻ tấn công thực hiện các hành động sau:

Tiết lộ mã nguồn của các tập lệnh PHP.
Thực thi mã PHP tùy ý trên máy chủ.

Điểm CVSS 
9.8

Ảnh hưởng

Lỗ hổng này ảnh hưởng đến các phiên bản sau:
PHP 8.1.* trước phiên bản 8.1.29
PHP 8.2.* trước phiên bản 8.2.20
PHP 8.3.* trước phiên bản 8.3.8

Khuyến nghị khắc phục

Nhằm đảm bảo an toàn thông tin cho hệ thống thông tin của đơn vị, góp phần đảm bảo an toàn cho không gian mạng Việt Nam, Trung tâm VNCERT/CC khuyến nghị người dùng cần cập nhật PHP lên các phiên bản an toàn:

PHP 8.1.29 hoặc cao hơn
PHP 8.2.20 hoặc cao hơn
PHP 8.3.8 hoặc cao hơn

Tác giả: VNCERT/CC

Nguồn tin: vncert.vn

Bạn đã không sử dụng Site, Bấm vào đây để duy trì trạng thái đăng nhập. Thời gian chờ: 60 giây