Phát hiện lỗ hổng nghiêm trọng SQl Injection gây ảnh hưởng đến một triệu trang web WordPress

Thứ hai - 22/04/2024 16:55 115 0
Một plugin thương mại dành cho WordPress có tên LayerSlider, đang được sử dụng trong hơn một triệu trang web tồn tại lỗ hổng SQL injection mà không yêu cầu người dùng xác thực.
SQL

LayerSlider là một công cụ linh hoạt dùng để tạo các thanh trượt (sliders) tùy ý theo kích thước màn hình hiển thị, thư viện ảnh và hoạt ảnh trên các trang web WordPress, cho phép người dùng xây dựng các thành phần trực quan với nội dung động trên nền tảng trực tuyến.

Lỗ hổng nghiêm trọng có định danh CVE-2024-2879 (điểm CVSS: 9,8), do nhà nghiên cứu AmrAwad phát hiện và báo cáo cho công ty bảo mật Wordfence của WordPress vào ngày 25/3/2024. AmrAwad đã nhận được 5.500 USD tiền thưởng cho việc báo cáo lỗ hổng.

Lỗ hổng ảnh hưởng đến các phiên bản plugin từ 7.9.11 đến 7.10.0, có thể cho phép kẻ tấn công trích xuất dữ liệu nhạy cảm như mã băm mật khẩu từ cơ sở dữ liệu của trang web, khiến chúng có nguy cơ bị chiếm đoạt hoặc vi phạm dữ liệu.

Chi tiết kỹ thuật được cung cấp trong báo cáo của Wordfence cho thấy lỗ hổng tồn tại trong quá trình xử lý tham số 'id' của chức năng 'ls_get_popup_markup' trong plugin.

Chức năng này xử lý tham số 'id' không đúng cách, cho phép kẻ tấn công chèn mã SQL độc hại vào các câu truy vấn, dẫn đến việc thực thi lệnh.
MN
Một phần của mã nguồn dễ bị tấn công (Nguồn: Wordfence)
Cấu trúc của các truy vấn có thể giới hạn cuộc tấn công, tuy nhiên tin tặc vẫn có thể khai thác lỗ hổng bằng cách sử dụng kỹ thuật tấn công time-based blind SQL injection, trong đó kẻ tấn công sẽ dựa vào thời gian phản hồi để suy đoán dữ liệu trong cơ sở dữ liệu.

Mặc dù bị hạn chế, CVE-2024-2879 vẫn cho phép các tác nhân độc hại trích xuất thông tin từ cơ sở dữ liệu của trang web, bao gồm mã băm của mật khẩu và thông tin nhạy cảm của người dùng, mà không yêu cầu bất kỳ kiểm tra xác thực nào trên trang web.

Wordfence cho biết vấn đề càng trở nên trầm trọng hơn do các truy vấn không được xử lý bằng chức năng '$wpdb->prepare()' của WordPress, chức năng ngăn chặn việc chèn câu lệnh SQL bằng cách đảm bảo rằng đầu vào của người dùng được kiểm tra và sàng lọc trước khi sử dụng trong các truy vấn cơ sở dữ liệu.

Nhóm phát triển plugin Kreatura Team đã phát hành bản cập nhật bảo mật vào ngày 27/3/2024, chưa đầy 48 giờ sau khi được báo cáo lỗ hổng.

Người dùng LayerSlider nên nâng cấp lên phiên bản 7.10.1 ngay lập tức để giải quyết lỗ hổng nghiêm trọng này.

Để giảm thiểu các rủi ro bị tấn công, quản trị viên trang WordPress cần thường xuyên kiểm tra, cập nhật tất cả các plugin đang sử dụng và vô hiệu hóa những plugin không cần thiết, sử dụng mật khẩu mạnh, đồng thời vô hiệu hóa các tài khoản không còn hoạt động.

Tác giả: Nguyễn Hà Phương

Nguồn tin: Tạp chí An toàn thông tin

Bạn đã không sử dụng Site, Bấm vào đây để duy trì trạng thái đăng nhập. Thời gian chờ: 60 giây